Skip to main content
VulnerabilityPublished

CVE-2026-55447: langflow · UNIX Symbolic Link (Symlink) Following

Affects langflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.6 Critical : upgrade to 1.9.2 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade langflow and langflow-ai/langflow to 1.9.2.

Affected software

ProductAffectedFixed in
langflow-ailangflowAffected
  • <1.9.2
Fixed in
  • 1.9.2
GitHublangflow-ai/langflowpkg:github/langflow-ai/langflowOther threatsAffected
  • <1.9.2
Fixed in
  • 1.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade langflow to version 1.9.2 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.2, by controlling a files that are digested into the RAG, an attacker can direct the node to read any file on the file-system by absolute path. All components based on BaseFileComponent are vulnerable to the vulnerability. This includes Docling (DoclingInlineComponent), Docling Serve, DoclingRemoteComponent), Read File (FileComponent), NVIDIA Retriever Extraction (NvidiaIngestComponent), Video File (VideoFileComponent), and Unstructured API (UnstructuredComponent). This vulnerability is fixed in 1.9.2.

References

Community reviews

Loading reviews…