Skip to main content
VulnerabilityPublished

CVE-2026-55598: madeofpendletonwool PinePods · Server-Side Request Forgery

Affects madeofpendletonwool PinePodsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.9.0 as a priority.

Data as of 30 Oct 2026, 20:42 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.19.1
Patch
Available – fixed in 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade madeofpendletonwool PinePods to 0.9.0.

Affected software

ProductAffectedFixed in
madeofpendletonwoolPinePodsAffected
  • <0.9.0
Fixed in
  • 0.9.0

AI-suggested

Upgrade PinePods to version 0.9.0 or later, where this SSRF vulnerability is fixed. Until upgrading, consider disabling server downloads if feasible to prevent exploitation. No other vendor advisory mitigation instructions are provided.

Description

PinePods versions prior to 0.9.0 contain a server-side request forgery (SSRF) vulnerability that allows authenticated low-privilege users to make the server perform HTTP GET and HEAD requests to arbitrary internal and external URLs. This occurs because the application does not validate or restrict URLs in podcast RSS feed enclosures, enabling attackers to access internal services, including cloud metadata endpoints. The vulnerability is fixed in version 0.9.0.

References

Community reviews

Loading reviews…