CVE-2026-56834: MervinPraison PraisonAI · Path Traversal
Affects MervinPraison PraisonAISource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 4.6.59 soon.
Data as of 26 Oct 2026, 14:18 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.59
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade MervinPraison PraisonAI to 4.6.59.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MervinPraisonPraisonAI | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PraisonAI to version 4.6.59 or later, where this path traversal vulnerability has been fixed. The patch enforces proper validation of artifact paths to ensure they reside within the configured artifact base directory and are created by the configured store. Until upgrading, restrict access to the Dynamic Context Discovery feature and limit who can supply artifact tool arguments to trusted users only.
Description
PraisonAI versions from 3.8.1 up to but not including 4.6.59 contain a path traversal vulnerability in the Dynamic Context Discovery feature. This flaw allows unauthorized reading of arbitrary files on the host filesystem by manipulating artifact tool arguments. The vulnerability arises because the artifact tools do not verify that the supplied paths are within the configured artifact base directory or created by the configured store. This can expose sensitive files such as .env files, cloud credentials, SSH keys, and source code. The issue is fixed in version 4.6.59.