Skip to main content
VulnerabilityPublished

CVE-2026-56839: MervinPraison PraisonAI · Path Traversal

Affects MervinPraison PraisonAISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 4.6.59 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.59
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PraisonAI and mervinpraison/PraisonAI to 4.6.59.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • <4.6.59
Fixed in
  • 4.6.59
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threatsAffected
  • <4.6.59
Fixed in
  • 4.6.59

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PraisonAI to version 4.6.59 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Since this is not a cloud service, remediation depends on applying the official fix.

Description

PraisonAI is a multi-agent teams system. Prior to 4.6.59, the CODE_TOOLS wrappers keep _workspace_root as None and pass workspace=None to read_file, search_replace, and apply_diff helpers that enforce path containment only for a truthy workspace. An application that exposes code_read_file, code_search_replace, or code_apply_diff before set_workspace can therefore let prompt-influenced calls read and modify files outside the intended project directory, while explicitly configured workspaces remain effective. This vulnerability is fixed in 4.6.59.

References

Community reviews

Loading reviews…