Skip to main content
VulnerabilityPublished Updated

CVE-2026-57119: MervinPraison PraisonAI · Path Traversal

Affects MervinPraison PraisonAISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.6.59 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.59
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PraisonAI and mervinpraison/PraisonAI to 4.6.59.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • <4.6.59
Fixed in
  • 4.6.59
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threatsAffected
  • <4.6.59
Fixed in
  • 4.6.59

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PraisonAI to version 4.6.59 or later, where this path traversal vulnerability is fixed. No other mitigation is required as the fix is official and addresses the root cause.

Description

PraisonAI is a multi-agent teams system. Prior to 4.6.59, the unauthenticated Jobs API accepts an absolute or traversing agent_file path in POST /api/v1/runs and passes it to the job executor without a workspace allowlist or boundary check. A remote caller can cause the server to open files accessible to the service account, exposing credentials, keys, environment variables, and other local data. This vulnerability is fixed in 4.6.59.

References

Community reviews

Loading reviews…