CVE-2026-57125: MervinPraison PraisonAI · Missing Authentication
Affects MervinPraison PraisonAISource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.6.59 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.59, 1.6.59
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade PraisonAI and mervinpraison/PraisonAI to 4.6.59; praisonaiagents and mervinpraison/praisonaiagents to 1.6.59.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MervinPraisonPraisonAI | Affected
| Fixed in
|
| MervinPraisonpraisonaiagents | Affected
| Fixed in
|
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threats | Affected
| Fixed in
|
GitHubmervinpraison/praisonaiagentspkg:github/mervinpraison/praisonaiagentsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PraisonAI to version 4.6.59 or later and praisonaiagents to version 1.6.59 or later to apply the official fix. These versions contain patches that enforce proper authentication and approval checks, mitigating the vulnerability.
Description
PraisonAI is a multi-agent teams system. Prior to praisonai 4.6.59 and praisonaiagents 1.6.59, the unauthenticated POST /api/v1/runs Jobs API accepts attacker-controlled agent_yaml, and the approve field can mark execute_command as YAML-approved before @require_approval checks critical tools. This chain allows a remote caller to cause a configured language model agent to invoke arbitrary operating-system commands without credentials or operator interaction. This vulnerability is fixed in praisonai 4.6.59 and praisonaiagents 1.6.59 as fixed versions.