CVE-2026-57817: Apache CXF · Improper Input Validation
Affects Apache CXFSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 4.2.3 : patch Apache CXF soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.3, 4.1.8, 3.6.12
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache to 4.2.3, 4.1.8 or 3.6.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache CXF | Affected
| Fixed in
|
| Apache Software FoundationApache CXF | Affected
| Fixed in
|
| Apache Software FoundationApache CXF | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.cxf:cxf-rt-rs-security-sso-oidcpkg:maven/Apache Software Foundation/org.apache.cxf:cxf-rt-rs-security-sso-oidcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache CXF to versions 4.2.3, 4.1.8, or 3.6.12 or later, which contain fixes for this vulnerability. Patch status is not explicitly stated as 'official-fix' in the vendor advisory, but the recommended upgrade versions indicate an official fix is available. No other mitigation or temporary workaround is provided.
Description
CVE-2026-57817 is a high-severity vulnerability in Apache CXF related to improper input validation of the c_hash parameter in OpenID Connect Hybrid Flow. If an Apache CXF relying party (RP) integrates with a non-compliant or misconfigured Identity Provider (IdP) that omits the c_hash, the RP is vulnerable to authorization code substitution or injection attacks. Fixed versions include 4.2.3, 4.1.8, and 3.6.12.