CVE-2026-58177: Apache Traffic Server · Out-of-bounds Write
Affects Apache Traffic ServerSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 10.1.4 : patch Apache Traffic Server soon.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.1.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Traffic Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache Traffic Server to version 10.1.4 or later, as this version contains the fix for the described vulnerabilities. Patch status is confirmed by the vendor's recommendation to upgrade. No alternative mitigations are indicated.
Description
CVE-2026-58177 is a high severity vulnerability in Apache Traffic Server's Cripts framework involving out-of-bounds write, path traversal, and use-after-free errors. It affects versions from 10.0.0 through 10.1.3. The issue can lead to partial confidentiality and integrity loss, and high availability impact. Users are advised to upgrade to version 10.1.4, which addresses the vulnerability.