Skip to main content
VulnerabilityPublished Updated

CVE-2026-58187: Apache Traffic Server · Out-of-bounds Write

Affects Apache Traffic ServerSource CVE Database V5

0

Not known to be exploited · CVSS 3.7 Low · fixed in 9.2.15 : update Apache Traffic Server when convenient.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.15
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Traffic ServerAffected
  • >=8.0.0 <=8.1.11
  • >=9.0.0 <=9.2.14
  • >=10.0.0 <=10.1.3
Fixed in–

AI-suggested

Users should upgrade affected Apache Traffic Server installations to version 9.2.15 or 10.1.4, which contain fixes for this vulnerability. No other mitigation or temporary workaround is specified. Patch status is confirmed by the vendor advisory recommending these versions.

Description

The Apache Traffic Server multiplexer plugin overruns its chunk-decode buffer on upstream input, enabling denial of service. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

References

Community reviews

Loading reviews…