Skip to main content
VulnerabilityPublished

CVE-2026-59932: PHPOffice PhpSpreadsheet · Uncontrolled Resource Consumption

Affects PHPOffice PhpSpreadsheetSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 5.8.1 : patch PHPOffice PhpSpreadsheet soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.8.1, 3.10.7, 2.4.7 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PHPOfficePhpSpreadsheetAffected
  • >=4.0.0 <5.8.1
Fixed in
  • 5.8.1
PHPOfficePhpSpreadsheetAffected
  • >=3.3.0 <3.10.7
Fixed in
  • 3.10.7
PHPOfficePhpSpreadsheetAffected
  • >=2.2.0 <2.4.7
Fixed in
  • 2.4.7
PHPOfficePhpSpreadsheetAffected
  • >=2.0.0 <2.1.18
Fixed in
  • 2.1.18
PHPOfficePhpSpreadsheetAffected
  • <1.30.6
Fixed in
  • 1.30.6

AI-suggested

A fix is available in PhpSpreadsheet versions 5.8.1, 3.10.7, 2.4.7, 2.1.18, and 1.30.6. Users should upgrade to these or later versions to remediate the vulnerability. Until upgraded, applications should consider restricting or validating .gnumeric file uploads to prevent processing of malicious compressed files.

Description

PhpSpreadsheet versions up to 5.8.0 (and several earlier branches) contain a vulnerability in the Gnumeric file reader where attacker-supplied .gnumeric files starting with gzip magic bytes can cause excessive memory consumption. This happens because the library calls gzdecode() on the full compressed contents without limiting the decompressed size, potentially leading to a denial of service by crashing the PHP process. The issue is fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18, and 1.30.6.

References

Community reviews

Loading reviews…