CVE-2026-62997: kedro-plugins · Deserialization of Untrusted Data
Affects kedro-pluginsSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 9.5.0 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.5.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade kedro-plugins and kedro-datasets to 9.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kedro-orgkedro-plugins | Affected
| Fixed in
|
PyPIkedro-datasetspkg:pypi/kedro-datasetsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Kedro-Datasets to version 9.5.0 or later where this issue is fixed. Avoid loading untrusted .pt model files with the experimental PyTorchDataset component, especially on PyTorch versions earlier than 2.6. Since the vulnerability is fixed in 9.5.0, applying this official fix is the recommended remediation.
Description
Kedro-Datasets versions from 5.0.0 up to but not including 9.5.0 contain a deserialization vulnerability in the experimental PyTorchDataset component. This component loads .pt model files using torch.load without enforcing the weights_only=True parameter, allowing maliciously crafted pickle-backed models to execute arbitrary code on PyTorch versions earlier than 2.6. The vulnerability only affects users who load untrusted model files via this opt-in component. The issue is resolved in version 9.5.0.
References
- github.com/kedro-org/kedro-plugins/security/advisories/GHSA-f9q4-h45w-jrrq (opens in a new tab)
- github.com/kedro-org/kedro-plugins/issues/1431 (opens in a new tab)
- github.com/kedro-org/kedro-plugins/pull/1433 (opens in a new tab)
- github.com/kedro-org/kedro-plugins/commit/4d6deb7a7ecba483d33fd43e2a6c063bcf22f413 (opens in a new tab)
- github.com/kedro-org/kedro-plugins/releases/tag/kedro-datasets-9.5.0 (opens in a new tab)