CVE-2026-64209: Linux kernel · Out-of-bounds Read
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 7.0.0-28.28~24.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-28.28~24.04.1, 7.0.0-1016.16~24.04.1, 7.0.0-28.28 +12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A vendor-provided patch is available and should be applied to affected Linux kernel versions to resolve this vulnerability. The patch corrects the boundary check in the qmp-usbc driver to prevent out-of-bounds array access. Users should update to fixed kernel versions as per the vendor advisory. No additional mitigation steps are indicated.
Description
A vulnerability in the Linux kernel's Qualcomm USB PHY driver (qmp-usbc) was fixed to address an out-of-bounds array access caused by incorrect boundary checking in dp swing configuration tables. The issue allowed an index of 4 to be accessed in 4x4 arrays, which should only allow indices 0-3. This flaw could lead to memory corruption and denial of service. The vulnerability has a CVSS score of 7.1 and affects multiple Linux kernel versions prior to 7.0.0-28.28 and specific other versions. A patch is available to correct this issue.
References
- ubuntu.com/security/CVE-2026-64209 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64209 (opens in a new tab)
- git.kernel.org/linus/ea17fc4d7dc2ba6459b1a318962960520201baf1 (opens in a new tab)
- git.kernel.org/stable/c/cb35af6e7f3d5628178b58c631e305b1def8edf7 (opens in a new tab)
- git.kernel.org/stable/c/ea17fc4d7dc2ba6459b1a318962960520201baf1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-64209 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)