Skip to main content
VulnerabilityPublished Updated

CVE-2026-46130: Linux kernel · take 3

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-46130

Not known to be exploited · CVSS 7.1 High · fixed in 7.0.0-28.28~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-28.28~24.04.1, 7.0.0-1016.16~24.04.1, 6.8.0-1035.38 +12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-28.28
Fixed in
  • 7.0.0-28.28
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1010.10
Fixed in
  • 7.0.0-1010.10
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1003.4
Fixed in
  • 7.0.0-1003.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in linux-hwe-edge kernel versions 7.0.0-28.28 and later. Users should update to these fixed versions or later to remediate the vulnerability. No additional mitigation steps are required as the issue is resolved by the official fix.

Description

A vulnerability in the Linux kernel's dm-verity-fec component was fixed that addressed an out-of-bounds read issue when reading parity bytes split across blocks. This flaw occurs under specific non-default configurations of fec_roots and low memory conditions, causing the fec_decode_bufs() function to read beyond the parity block buffer. The issue was resolved by refactoring how parity blocks are read. Multiple affected versions of the linux-hwe-edge kernel were identified and fixed in subsequent releases. The vulnerability has a CVSS score of 7.1, indicating a high impact on confidentiality and availability but no known exploitation in the wild.

References

Community reviews

Loading reviews…