Skip to main content
VulnerabilityPublished Updated

CVE-2026-64286: Linux kernel · KVM: arm64: Clear __hyp_running_vcpu when flushing the pKVM hyp vCPU

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-64286· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 6.8.0-147.147 : patch Linux kernel soon.

Data as of 6 Nov 2026, 17:27 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1012.12~24.04.1 +30
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to one of the fixed Linux kernel versions such as 6.8.0-147.147, 6.8.0-1067.70, or 7.0.0-1012.12~24.04.1. Users should follow the vendor advisory from Ubuntu (USN-8726-1) for detailed update instructions. No additional mitigations are required once the patch is applied.

Description

A vulnerability in the Linux kernel's KVM implementation for arm64 was fixed by clearing the __hyp_running_vcpu field when flushing the pKVM hyp vCPU. The flaw involved improper handling of the host vCPU context, which could lead to dereferencing an invalid pointer at EL2. This issue affects multiple Linux kernel versions prior to 6.8.0 and 7.0.0 releases and has been addressed in updated kernel versions.

References

Community reviews

Loading reviews…