Skip to main content
VulnerabilityPublished Updated

CVE-2026-64287: Linux kernel · KVM: arm64: Bound used_lrs when flushing the pKVM hyp vCPU

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-64287· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 6.8.0-147.147 : patch Linux kernel soon.

Data as of 6 Nov 2026, 17:27 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1012.12~24.04.1 +30
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple Linux kernel versions including 6.8.0-147.147 and 7.0.0-1012.12~24.04.1. Users should update to these or later fixed kernel versions to remediate the vulnerability. No additional mitigations are required as the issue is resolved by the official fix.

Description

A vulnerability in the Linux kernel's KVM arm64 implementation allowed improper handling of the vGIC list registers during the pKVM hyp vCPU flush operation. The flaw involved using an unbounded value from the host to index into the virtual GIC list registers, potentially leading to out-of-bounds access at EL2. This could result in privilege escalation or system compromise. The issue has been fixed by clamping the used_lrs value to the number of implemented list registers. Multiple Linux kernel versions are affected, and patches have been released.

References

Community reviews

Loading reviews…