Skip to main content
VulnerabilityPublished Updated

CVE-2026-64319: Linux kernel · nvmet-auth: validate reply message payload bounds against transfer length

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-64319· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 6.8.0-147.147 : patch Linux kernel as a priority.

Data as of 6 Nov 2026, 17:27 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Linux)CVSS 3.19.1
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1012.12~24.04.1 +30
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vulnerability has been fixed by adding proper bounds validation in the Linux kernel nvmet-auth module. Users should update to one of the fixed kernel versions including 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1012.12~24.04.1, and others listed in the established facts. No additional mitigations are indicated by the vendor advisory.

Description

A critical vulnerability in the Linux kernel's nvmet-auth module allows an attacker to cause out-of-bounds heap reads by sending a crafted DHCHAP_REPLY message with manipulated hash length and DH value length fields. This flaw occurs because the kernel does not properly validate these lengths against the allocated buffer size before accessing variable-length arrays. The vulnerability is exploitable pre-authentication and can lead to information disclosure and denial of service. Multiple Linux kernel versions prior to fixed releases are affected. A patch correcting the bounds validation has been released.

References

Community reviews

Loading reviews…