Skip to main content
VulnerabilityPublished

CVE-2026-6475: PostgreSQL · UNIX Symbolic Link (Symlink) Following

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High · fixed in 18.4 : patch PostgreSQL soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <14.23
  • <15.18
  • <16.14
  • <17.10
  • <18.4
Fixed in
  • 14.23
  • 15.18
  • 16.14
  • 17.10
  • 18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, administrators should avoid taking actions that involve moving files or snapshots between pg_basebackup/pg_rewind operations and server restarts. Monitoring PostgreSQL vendor communications for updates and applying patches promptly once released is recommended.

Description

CVE-2026-6475 is a high-severity vulnerability in PostgreSQL affecting versions prior to 18.4, 17.10, 16.14, 15.18, and 14.23. It involves symbolic link (symlink) following in the pg_basebackup plain format and pg_rewind utilities, allowing an origin superuser to overwrite local files such as /var/lib/postgres/. bashrc. This can lead to hijacking the operating system account if relevant actions are taken between these commands and server restart. The vulnerability relies on the implicit trust of the origin superuser when starting the server, especially with features like shared_preload_libraries.

References

Community reviews

Loading reviews…