Skip to main content
VulnerabilityPublished

CVE-2026-6476: PostgreSQL · SQL Injection

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 18.4 or 17.10 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PostgreSQL to 18.4 or 17.10.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • =17
  • =18
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict pg_create_subscription rights to trusted users only and monitor for unusual activity related to subscription creation. Avoid running pg_createsubscriber in environments where untrusted users have subscription creation privileges.

Description

CVE-2026-6476 is a high-severity SQL injection vulnerability in PostgreSQL affecting versions 17 and 18 prior to 17.10 and 18.4, respectively. It allows an attacker with pg_create_subscription rights to execute arbitrary SQL commands with superuser privileges when the pg_createsubscriber function runs. Versions before PostgreSQL 17 are not affected.

References

Community reviews

Loading reviews…