Skip to main content
VulnerabilityPublished Updated

CVE-2026-6477: PostgreSQL · Use of Inherently Dangerous Function

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High · fixed in 18.4 : patch PostgreSQL soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <14.23
  • <15.18
  • <16.14
  • <17.10
  • <18.4
Fixed in
  • 14.23
  • 15.18
  • 16.14
  • 17.10
  • 18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in PostgreSQL versions 18.4, 17.10, 16.14, 15.18, and 14.23 and later. Users should upgrade to these fixed versions or later. Until patched, users should avoid connecting to untrusted or potentially compromised PostgreSQL servers using psql, pg_dump, or other client tools that use the vulnerable libpq functions. The vendor advisory explicitly recommends only connecting to trusted servers as a mitigation. No other specific mitigations are noted.

Description

Use of inherently dangerous function PQfn(..., result_is_int=0, ...) in PostgreSQL libpq lo_export(), lo_read(), lo_lseek64(), and lo_tell64() functions allows the server superuser to overwrite a client stack buffer with an arbitrarily-large response. Like gets(), PQfn(..., result_is_int=0, ...) stores arbitrary-length, server-determined data into a buffer of unspecified size. Because both the \lo_export command in psql and pg_dump call lo_read(), the server superuser can overwrite pg_dump or psql stack memory. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

References

Community reviews

Loading reviews…