Skip to main content
VulnerabilityPublished Updated

CVE-2026-6478: PostgreSQL · Covert Timing Channel

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium · fixed in 18.4 : update PostgreSQL when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <18.4
  • <17.10
  • <16.14
  • <15.18
  • <14.23
Fixed in
  • 18.4
  • 17.10
  • 16.14
  • 15.18
  • 14.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in PostgreSQL versions 14.23, 15.18, 16.14, 17.10, and 18.4 and later, as provided by Red Hat security advisories. Users should upgrade to these fixed versions. Additionally, to mitigate the vulnerability, users must ensure that no PostgreSQL user passwords are hashed using MD5. This can be done by altering user passwords to trigger migration to stronger hashing algorithms such as scram-sha-256. For example, execute: ALTER USER username WITH PASSWORD 'new_password'; This requires users to re-authenticate, and services relying on these credentials may need to be restarted to pick up the changes. No other mitigations are indicated by the vendor advisory.

Description

Covert timing channel in comparison of MD5-hashed password in PostgreSQL authentication allows an attacker to recover user credentials sufficient to authenticate. This does not affect scram-sha-256 passwords, the default in all supported releases. However, current databases may have MD5-hashed passwords originating in upgrades from PostgreSQL 13 or earlier. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

References

Community reviews

Loading reviews…