Skip to main content
VulnerabilityPublished

CVE-2026-6479: PostgreSQL · Uncontrolled Recursion

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 18.4 : patch PostgreSQL soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23

AI-suggested

If you cannot patch yet, restrict access to PostgreSQL AF_UNIX and TCP sockets to trusted users only, and consider disabling SSL and GSS negotiation if feasible as a temporary measure. Monitor PostgreSQL server stability and logs for signs of exploitation attempts.

Description

CVE-2026-6479 is a high-severity vulnerability in PostgreSQL affecting versions prior to 18.4, 17.10, 16.14, 15.18, and 14.23. It involves uncontrolled recursion during SSL and GSS negotiation, which can be exploited by an attacker with access to a PostgreSQL AF_UNIX socket to cause a sustained denial of service. If SSL and GSS are disabled, the vulnerability can also be triggered via a PostgreSQL TCP socket. There is no confirmed patch or official remediation guidance available at this time.

References

Community reviews

Loading reviews…