CVE-2026-6575: PostgreSQL · Buffer Over-read
Affects PostgreSQLSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 18.4 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade PostgreSQL to 18.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQL | Affected
| Fixed in
|
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restricting table maintainer privileges to trusted users may reduce risk.
Description
CVE-2026-6575 is a medium-severity buffer over-read vulnerability in PostgreSQL version 18 prior to 18.4. The issue occurs in the pg_restore_attribute_stats() function, which improperly handles array values of unmatched length, causing query planning to read beyond the end of an array. This flaw allows a table maintainer to infer memory contents beyond the intended array boundary. Versions before PostgreSQL 18 are not affected.