Skip to main content
VulnerabilityPublished Updated

CVE-2026-67330: better-auth scim · Improper Input Validation

Affects better-auth scimSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical · fixed in 1.6.22 : patch better-auth scim as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.22
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
better-authscimAffected
  • >=1.4.0-beta.27
Fixed in–
better-authscimAffected
  • >=1.7.0-beta.0
Fixed in–
npm@better-auth/scimpkg:npm/@better-auth/scimOther threatsAffected
  • =1.4.0-beta.27
  • <=1.6.21
  • =1.7.0-beta.0
  • =1.7.0-beta.9
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in better-auth scim versions 1.6.22 and 1.7.0-beta.10 (1.7.0-rc.0). Users should upgrade to these versions or later to remediate this vulnerability. No vendor advisory content is provided to indicate alternative mitigations or temporary workarounds.

Description

@better-auth/scim (a better-auth plugin) versions >= 1.4.0-beta.27 through <= 1.6.21 and >= 1.7.0-beta.0 through <= 1.7.0-beta.9 contain an authorization bypass. SCIM token issuance did not reject provider IDs already used by existing SSO, SAML, OIDC, generic OAuth, or social account providers, and the same logical provider ID was used for both SCIM provider configuration and account ownership. An authenticated user could mint a SCIM token whose provider ID collided with an existing provider namespace, causing SCIM user routes to resolve account rows the token never provisioned. This allowed listing, reading, updating (including rewriting global profile/email fields without uniqueness checks), and deleting global user accounts and sessions, resulting in account takeover and unauthorized deprovisioning. Fixed in 1.6.22 and 1.7.0-beta.10 (1.7.0-rc.0).

References

Community reviews

Loading reviews…