Skip to main content
VulnerabilityPublished Updated

CVE-2026-67551: Apache Qpid Proton Dotnet · Excessive Memory Allocation

Affects Apache Qpid Proton DotnetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.1.0 soon.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade apache.qpid.proton.dotnet to 1.1.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Qpid Proton DotnetAffected
  • <=1.0.0
Fixed in–
NuGetapache.qpid.proton.dotnetpkg:nuget/apache.qpid.proton.dotnetOther threatsAffected
  • <1.1.0
Fixed in
  • 1.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Qpid Proton Dotnet to version 1.1.0 or later, which contains the fix for this vulnerability. No other mitigation or temporary workaround is indicated.

Description

pre-authentication attacker could leverage type size/count handling to cause excessive allocation leading to potential denial of service. This issue affects Apache Qpid Proton-Dotnet: through 1.0.0. Users are recommended to upgrade to version 1.1.0, which fixes the issue.

References

Community reviews

Loading reviews…