Skip to main content
VulnerabilityPublished

CVE-2026-67555: Apache Qpid Proton Dotnet · Unthrottled Resource Allocation

Affects Apache Qpid Proton DotnetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.1.0 when convenient.

Data as of 3 Nov 2026, 10:58 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade apache.qpid.proton.dotnet to 1.1.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Qpid Proton DotnetAffected
  • <=1.0.0
Fixed in–
NuGetapache.qpid.proton.dotnetpkg:nuget/apache.qpid.proton.dotnetOther threatsAffected
  • <1.1.0
Fixed in
  • 1.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Qpid Proton-Dotnet to version 1.1.0 or later, where this issue is fixed. No other mitigations or temporary workarounds are indicated.

Description

A resource allocation vulnerability exists in Apache Qpid Proton-Dotnet through version 1.0.0, where the maximum number of transfer frames per incoming delivery could not be limited. This flaw allows an authenticated attacker to cause excessive resource consumption, potentially leading to denial of service. The issue is fixed in version 1.1.0.

References

Community reviews

Loading reviews…