Skip to main content
VulnerabilityPublished

CVE-2026-67554: Apache Qpid Proton Dotnet · Unchecked Input for Loop Condition

Affects Apache Qpid Proton DotnetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium · fixed in 1.1.0 : update Apache Qpid Proton Dotnet when convenient.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Qpid Proton DotnetAffected
  • <=1.0.0
Fixed in–
NuGetapache.qpid.proton.dotnetpkg:nuget/apache.qpid.proton.dotnetOther threatsAffected
  • <=1.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Qpid Proton Dotnet to version 1.1.0 or later, where this issue is fixed. No other mitigations or temporary workarounds are indicated.

Description

CVE-2026-67554 is a denial of service vulnerability in Apache Qpid Proton Dotnet where an authenticated attacker can send a disposition frame with large or illegal ranges. This causes excessive CPU usage due to improper handling of loop conditions. The issue affects versions up to and including 1.0.0. Upgrading to version 1.1.0 resolves the problem.

References

Community reviews

Loading reviews…