Skip to main content
VulnerabilityPublished Updated

CVE-2026-68448: Linux kernel · ovl: check access to copy_file_range source with src mounter creds

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-68448· Medium

Not known to be exploited · CVSS 2.0 Medium · fixed in 7.0.0-1014.14~24.04.1 : update Linux kernel when convenient.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 4.0 base score
2.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1014.14~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +11
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch fixing this vulnerability is available in Linux kernel versions 7.0.0-1014.14~24.04.1 and later. Users should upgrade to these fixed versions to remediate the issue. No additional mitigation is required as the fix corrects the credential checks. Userspace fallback to regular copy operations mitigates denial of access cases.

Description

CVE-2026-68448 is a vulnerability in the Linux kernel's overlay filesystem (overlayfs) related to the copy_file_range operation. The flaw involves incorrect credential checks when copying files across different overlayfs mounts, potentially allowing read access to files that should be denied. This issue was fixed by verifying read access with the correct source overlayfs mounter credentials. The vulnerability has a low severity score and does not have known exploits in the wild. Fixed versions of the Linux kernel are available.

References

Community reviews

Loading reviews…