CVE-2026-68472: Linux kernel · wifi: cfg80211: validate EHT MLE before MLD ID read
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in 7.0.0-1014.14~24.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1014.14~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +11
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8888-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8889-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-3 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and fixed versions include Linux kernel releases 7.0.0-1014.14~24.04.1 and later variants as listed. Users should upgrade to these fixed kernel versions to remediate the vulnerability. No additional mitigations are indicated by the vendor advisory.
Description
A vulnerability in the Linux kernel's wifi cfg80211 subsystem allows improper validation of the EHT Multi-Link Element (MLE) before reading the Multi-Link Device (MLD) ID. This flaw could lead to out-of-bounds reads when processing malformed EHT MLEs sent by a malicious access point. The issue is fixed by validating the MLE type and size before accessing internal fields, preventing the read beyond element boundaries.
References
- ubuntu.com/security/CVE-2026-68472 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-68472 (opens in a new tab)
- git.kernel.org/linus/74e27cd1d98b546fdb276008a83708d062339661 (opens in a new tab)
- git.kernel.org/stable/c/3b0505e43da8fb5b2a7994c3c3604e5a74692154 (opens in a new tab)
- git.kernel.org/stable/c/584657c5fc58d7a840623a2fa06331c9661dd0f1 (opens in a new tab)
- git.kernel.org/stable/c/74e27cd1d98b546fdb276008a83708d062339661 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8889-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-3 (opens in a new tab)