Skip to main content
VulnerabilityPublished Updated

CVE-2026-68979: Apache NiFi · Missing Authorization

Affects Apache NiFiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium · fixed in 2.11.0 : update Apache NiFi when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.11.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L/S:N/AU:Y/R:U/V:C/RE:L/U:Clear

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache NiFiAffected
  • >=1.10.0 <=2.10.0
Fixed in–
Mavenorg.apache.nifi/nifipkg:maven/org.apache.nifi/nifiOther threatsAffected
  • =1.10.0
  • <=2.10.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Apache NiFi version 2.11.0 or later, which includes proper authorization checks on components referencing Parameter Contexts during updates. This fix aligns the authorization enforcement with other API methods and prevents unauthorized parameter modifications affecting referencing components. Patch status is not explicitly confirmed beyond the recommendation to upgrade; check the vendor advisory for the latest guidance.

Description

Apache NiFI 1.10.0 through 2.10.0 provide a Parameter Context update REST API method that does not enforce authorization checking on components referencing Parameter values. Updating a Parameter Context can change parameter values that affect referencing components, but framework authorization was limited to read and write privileges on the Parameter Context itself. As a result of the missing authorization, an authenticated user authorized to modify a Parameter Context, but not authorized on referencing components, could alter Parameter values affecting those components. In deployments where a Parameter value contains executable scripting content, updating a Parameter can result in code execution during automatic component validation, without starting the referencing component. The impact was limited to stopped components by existing verification checks, and the issue applies only to deployments that use component-level authorization policies. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, which aligns the Parameter Context update method authorization with other methods, adding authorization checking on affected components.

References

Community reviews

Loading reviews…