CVE-2026-86089: Apache NiFi · Missing Authorization
Affects Apache NiFiSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low · fixed in 2.12.0 : update Apache NiFi when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/S:P/AU:Y/R:U/V:C/RE:L/U:ClearExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache NiFi | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.nifi:nifi-web-apipkg:maven/Apache Software Foundation/org.apache.nifi:nifi-web-apiOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Apache NiFi version 2.12.0 or later, which enforces authorization checks on source Process Groups during migration requests, filtering migration sources to only those Process Groups the user is authorized to read and requiring write access to the source Process Group. If component-level authorization policies for Process Groups are implemented, this vulnerability does not apply. No other mitigation is indicated.
Description
Apache NiFi 2.11.0 contains a missing authorization vulnerability in its REST API methods for migrating version-controlled Process Groups into Connectors. The vulnerability allows authenticated users with read or write access to a Connector to access or migrate Process Groups without proper authorization checks on those Process Groups. This can lead to unauthorized enumeration of Process Group details or migration of Process Groups without write access. The vulnerability is mitigated in Apache NiFi 2.12.0 by enforcing authorization checks on the source Process Groups during migration requests.