Skip to main content
VulnerabilityPublished

CVE-2026-81866: Apache NiFi · Missing Authorization

Affects Apache NiFiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 0.5 Low · fixed in 2.12.0 : update Apache NiFi when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
0.5Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:U/S:N/AU:Y/R:U/V:C/RE:L/U:Clear

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache NiFiAffected
  • >=2.9.0 <=2.11.0
Fixed in–
MavenApache Software Foundation/org.apache.nifi:nifi-web-apipkg:maven/Apache Software Foundation/org.apache.nifi:nifi-web-apiOther threatsAffected
  • >=2.9.0 <=2.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache NiFi to version 2.12.0 or later, which implements proper authorization checks for reading referenced Parameter Providers and verifies ownership of referenced Assets during Connector configuration update and verification. No other mitigation is required if the upgrade is applied.

Description

Apache NiFi versions 2.9.0 through 2.11.0 have a missing authorization vulnerability in the Connector configuration update and verification REST API methods. These methods do not properly enforce authorization checks on Assets and Secrets referenced in the configuration, allowing authenticated users with write privileges on a Connector to apply Secret values from Parameter Providers they are not authorized to read. Additionally, Asset identifiers are accepted without verifying ownership by the Connector. This issue is mitigated by upgrading to Apache NiFi 2.12.0, which enforces read access checks on Parameter Providers and verifies Asset ownership during configuration updates.

References

Community reviews

Loading reviews…