CVE-2026-69128: chartbrew · Path Traversal
Affects chartbrewSource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium : upgrade to 5.2.3 when convenient.
Data as of 6 Nov 2026, 21:34 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 4.6 |
|---|
- Patch
- Available – fixed in 5.2.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade chartbrew to 5.2.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| chartbrewchartbrew | Affected
| Fixed in
|
AI-suggested
Upgrade Chartbrew to version 5.2.3 or later, where this vulnerability is fixed. Users should ensure AI features are configured securely and restrict elevated privileges to trusted users. No other specific mitigations are indicated by the vendor advisory.
Description
CVE-2026-69128 is a path traversal vulnerability in Chartbrew versions 5.2.2 through before 5.2.3. It arises from the AI SQL blocklist failing to block certain PostgreSQL filesystem functions, especially when used with double-quoted identifiers. This allows users with Owner or Admin privileges and AI features enabled to bypass the blocklist and execute server-side file functions via PostgreSQL. The vulnerability is fixed in version 5.2.3.