CVE-2026-69257: FlowiseAI Flowise · Server-Side Request Forgery (SSRF)
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 3.1.3 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.3 or later, where this vulnerability is fixed by proper normalization of IPv4-mapped IPv6 addresses before deny list checks. No other mitigations are specified or required.
Description
Flowise versions prior to 3.1.3 contain a Server-Side Request Forgery (SSRF) vulnerability due to improper normalization of IPv4-mapped IPv6 addresses in its HTTP security module. This allows attackers controlling DNS resolution to bypass IP deny lists and make requests to localhost, internal services, or cloud metadata endpoints. The issue is fixed in version 3.1.3.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-c6xh-wv4j-ppv5 (opens in a new tab)
- github.com/FlowiseAI/Flowise/pull/6431 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/0fc769208395641c1411ccdb9c81416e54802155 (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (opens in a new tab)