CVE-2026-70410: Apache Calcite Avatica · Unsafe Reflection
Affects Apache Calcite AvaticaSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.29.0 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.29.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache to 1.29.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Calcite Avatica | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.calcite.avatica:avatica-corepkg:maven/Apache Software Foundation/org.apache.calcite.avatica:avatica-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Calcite Avatica to version 1.29.0 or later, where the unsafe reflection issue is fixed. This official fix restricts plugin instantiation to classes implementing the specified plugin interface, preventing arbitrary class initialization. No other mitigations are indicated by the vendor.
Description
CVE-2026-70410 is a vulnerability in Apache Calcite Avatica before version 1.29.0 involving unsafe reflection. The issue arises from plugin instantiation methods that allow arbitrary classes to be initialized via Class.forName(String), potentially triggering static initializer blocks. Although no known dangerous static initializers are widely used, the vulnerability could lead to unintended code execution. The vulnerability has a high severity score of 8.8. Users are advised to upgrade to version 1.29.0 where this issue is fixed.