CVE-2026-86792: Apache Airflow Apache Kafka provider · Unsafe Reflection
Affects Apache Airflow Apache Kafka providerSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.0.0 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow Apache Kafka provider and apache-airflow-providers-apache-kafka to 2.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow Apache Kafka provider | Affected
| Fixed in
|
PyPIapache-airflow-providers-apache-kafkapkg:pypi/apache-airflow-providers-apache-kafkaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to apache-airflow-providers-apache-kafka version 2.0.0 or later, which introduces an allowlist configuration option for connection-string callbacks, effectively preventing unsafe reflection. If upgrading is not immediately possible, ensure that Kafka event producers (dag_run_events_enabled and task_instance_events_enabled) remain disabled, which is the default setting. Deployments using Google Managed Kafka are not vulnerable due to internal overrides of user-supplied callbacks.
Description
Apache Airflow Apache Kafka provider versions 1.15.0 up to but not including 2.0.0 contain a vulnerability where externally controlled input in a Kafka connection's extra field is unsafely reflected and executed. This allows users with permission to edit Airflow connections to achieve arbitrary code execution in the scheduler process if Kafka event producers are enabled. The vulnerability is mitigated in version 2.0.0 and later by introducing an allowlist for connection-string callbacks. Deployments using Google Managed Kafka are not affected.
References
- github.com/apache/airflow/pull/72208 (opens in a new tab)
- lists.apache.org/thread/jl4gpok02313yh3rvtvj8qbo11c6zpr2 (opens in a new tab)
- openwall.com/lists/oss-security/2026/09/15/15 (opens in a new tab)
- lists.apache.org/thread/jl4gpok02313yh3rvtvj8qbo11c6zpr2?users@airflow.apache.org (opens in a new tab)