CVE-2026-70472: FlowiseAI Flowise · Improper Authorization
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 3.1.3 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Flowise version 3.1.3. Users should upgrade to version 3.1.3 or later to remediate this issue. There is no indication of alternative mitigations or temporary fixes. Patch status is confirmed by the vendor advisory stating the fix in 3.1.3.
Description
CVE-2026-70472 is an improper authorization vulnerability in FlowiseAI Flowise versions prior to 3.1.3. The issue allows an attacker to use a client-controlled credential parameter to access credentials belonging to other workspaces without proper authorization checks. This can lead to unauthorized use of OpenAI API keys, modification or deletion of victim vector stores and files, and potential billing impact on the victim's OpenAI account. The vulnerability violates multi-tenant boundaries and is fixed in version 3.1.3.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-chm3-vqcf-52rx (opens in a new tab)
- github.com/FlowiseAI/Flowise/pull/6170 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/d81483b70c997ddf981acc9c49fbd9a02fa345cd (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (opens in a new tab)