Skip to main content
VulnerabilityPublished

CVE-2026-70474: FlowiseAI Flowise · Incorrect Authorization

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 3.1.3 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.3.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.3
Fixed in
  • 3.1.3
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.3
Fixed in
  • 3.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.3 or later, where this authorization flaw is fixed. No other mitigation is indicated by the vendor advisory.

Description

FlowiseAI Flowise versions prior to 3.1.3 contain an incorrect authorization vulnerability in their OAuth2 credential endpoints. The endpoints authorize, callback, and refresh query credentials by ID without filtering by workspace ID, and some handlers are accessible without authentication. This flaw allows authenticated users to initiate OAuth2 flows using credentials from other workspaces and unauthenticated attackers to forge OAuth2 callbacks or refresh tokens for any credential. The issue is resolved in version 3.1.3.

References

Community reviews

Loading reviews…