CVE-2026-70589: TryGhost Ghost · Improper Input Validation
Affects TryGhost GhostSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 6.54.1 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.54.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade TryGhost Ghost to 6.54.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TryGhostGhost | Affected
| Fixed in
|
AI-suggested
Upgrade Ghost to version 6.54.1 or later, where the improper input validation issue has been fixed. Patch status is confirmed by the vendor stating the fix is included in 6.54.1.
Description
Ghost, a Node.js content management system, contains an improper input validation vulnerability in versions from 4.22.0 up to but not including 6.54.1. This flaw allowed users to redeem subscription offers that were no longer active. The issue is resolved in version 6.54.1.