CVE-2026-70596: TryGhost Ghost · Cross-site Scripting
Affects TryGhost GhostSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.54.1 when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-08-05.
- Patch
- Available – fixed in 6.54.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade TryGhost Ghost to 6.54.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TryGhostGhost | Affected
| Fixed in
|
AI-suggested
Upgrade Ghost to version 6.54.1 or later, where this vulnerability is fixed. No other mitigation is indicated or required according to the vendor advisory.
Description
Ghost, a Node.js content management system, had a cross-site scripting (XSS) vulnerability in versions from 4.9.0 up to but not including 6.54.1. This flaw allowed any staff user to insert malicious content into the feature_image_caption field of a post, which could be exploited to hijack another staff user's Ghost Admin session and escalate privileges. The vulnerability was fixed in version 6.54.1.
References
- github.com/TryGhost/Ghost/security/advisories/GHSA-pr22-p9rp-2cqv (opens in a new tab)
- github.com/TryGhost/Ghost/pull/29635 (opens in a new tab)
- github.com/TryGhost/Ghost/commit/a8bea3a4ceec4c852b880f4885119453c3d8588e (opens in a new tab)
- github.com/TryGhost/Ghost/releases/tag/v6.54.1 (opens in a new tab)