Skip to main content
VulnerabilityPublished

CVE-2026-71559: Apache Fory · Deserialization of Untrusted Data

Affects Apache ForySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.5.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache Fory to 1.5.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ForyAffected
  • >=0.16.0 <1.5.0
Fixed in
  • 1.5.0

AI-suggested

Users should upgrade Apache Fory to version 1.5.0 or later, which fixes this vulnerability. No other mitigations are indicated.

Description

CVE-2026-71559 is a deserialization of untrusted data vulnerability in the Go implementation of Apache Fory. An attacker can cause a denial of service by supplying crafted data with malformed type metadata, triggering an uncaught panic. This affects Apache Fory versions from 0.16.0 up to but not including 1.5.0. The issue is fixed in version 1.5.0.

References

Community reviews

Loading reviews…