CVE-2026-71560: Apache Fory · Deserialization of Untrusted Data
Affects Apache ForySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.5.0 as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache Fory to 1.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Fory | Affected
| Fixed in
|
AI-suggested
Users should upgrade to Apache Fory version 1.5.0 or later, which fixes this vulnerability. Applications that do not use Apache Fory C++ or do not utilize tagged integer fields are not affected and do not require action.
Description
CVE-2026-71560 is a critical vulnerability in Apache Fory C++ affecting versions from 0.14.0 before 1.5.0. It involves an out-of-bounds read during deserialization of structs containing tagged integer fields, which can lead to information disclosure or denial of service. The issue is fixed in Apache Fory 1.5.0. Applications not using Apache Fory C++ or tagged integer fields are not affected.