Skip to main content
VulnerabilityPublished Updated

CVE-2026-72317: Linux kernel · SUNRPC: pin upper

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 6.8.0-147.147 : patch Linux kernel as a priority.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1013.13~24.04.1 +27
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-34.34
Fixed in
  • 7.0.0-34.34
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.8
Fixed in
  • 7.0.0-1007.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Linux kernel versions 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1013.13~24.04.1, and related versions. Users and administrators should update to these fixed kernel versions to remediate the vulnerability. No additional mitigation actions are required beyond applying the official fixes.

Description

CVE-2026-72317 is a critical use-after-free vulnerability in the Linux kernel's SUNRPC subsystem affecting TLS-secured transports. The flaw occurs because the upper rpc_clnt pointer is not properly pinned across a delayed TLS connect worker, leading to a reference count underflow and potential memory corruption when a TLS handshake fails fatally. This vulnerability has been fixed in multiple Linux kernel versions starting from 6.8.0-147.147 and related releases.

References

Community reviews

Loading reviews…