Skip to main content
VulnerabilityPublished Updated

CVE-2026-7412: Eclipse BaSyx · Server-Side Request Forgery (SSRF)

Affects Eclipse BaSyxSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 2.0.0-milestone-10 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0-milestone-10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Eclipse BaSyx to 2.0.0-milestone-10.

Affected software

ProductAffectedFixed in
Eclipse FoundationEclipse BaSyxAffected
  • <2.0.0-milestone-10
Fixed in
  • 2.0.0-milestone-10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider restricting network access to the BaSyx server to trusted sources and monitor for unusual outbound HTTP requests. Avoid exposing the vulnerable versions to untrusted networks. Follow updates from the Eclipse Foundation for any forthcoming patches or official mitigations.

Description

CVE-2026-7412 is a high-severity server-side request forgery (SSRF) vulnerability in Eclipse BaSyx Java Server SDK versions prior to 2.0.0-milestone-10. The vulnerability arises because the Operation Delegation feature does not validate the destination URI of delegated requests, allowing unauthenticated remote attackers to make the server send blind HTTP POST requests to arbitrary internal or external targets. This can enable attackers to bypass network segmentation and potentially access isolated internal IT/OT infrastructure or cloud metadata services. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…