CVE-2026-75516: rabbitmq-java-client · Unthrottled Resource Allocation
Affects rabbitmq-java-clientSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 5.34.0 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.34.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade rabbitmq-java-client and com.rabbitmq/rabbitmq-java-client to 5.34.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rabbitmqrabbitmq-java-client | Affected
| Fixed in
|
Mavencom.rabbitmq/rabbitmq-java-clientpkg:maven/com.rabbitmq/rabbitmq-java-clientOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to rabbitmq-java-client version 5.34.0 or later, where this issue is fixed. No other mitigation is indicated.
Description
CVE-2026-75516 is a high-severity vulnerability in the rabbitmq-java-client library prior to version 5.34.0. It involves improper handling of frame size limits during AMQP connection negotiation, allowing a malicious server or man-in-the-middle attacker to cause excessive memory allocation. This can lead to client process termination due to memory exhaustion. The issue is fixed in version 5.34.0.
References
- github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-jh4v-gfqj-7rhx (opens in a new tab)
- github.com/rabbitmq/rabbitmq-java-client/pull/2015 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-java-client/pull/2016 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-java-client/commit/6d7c2bfe89796ca34d3531098fb59dd657fea39e (opens in a new tab)
- github.com/rabbitmq/rabbitmq-java-client/commit/e7f10bf99aee103dd9f64b3e52a725fc9f9d3763 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-java-client/releases/tag/v5.34.0 (opens in a new tab)