Skip to main content
VulnerabilityPublished

CVE-2026-75973: Apache Tomcat · Improper Authentication

Affects Apache TomcatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache TomcatAffected
  • >=11.0.0-M1 <=11.0.25
  • >=10.1.0-M1 <=10.1.59
  • >=9.0.0.M4 <=9.0.121
  • >=8.5.0 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • >=11.0.0-M1 <=11.0.25
  • >=10.1.0-M1 <=10.1.59
  • >=9.0.0.M4 <=9.0.121
  • >=8.5.0 <=8.5.100
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat versions to 11.0.26, 10.1.60, or 9.0.122 or later, where the issue is fixed. No other mitigation or temporary workaround is indicated. Applying the official fixes is the recommended remediation.

Description

CVE-2026-75973 is an improper authentication vulnerability in Apache Tomcat affecting multiple versions. When Jakarta Authentication is configured with SimpleAuthConfigProvider as the default provider and multiple web applications use it, the authentication realm from the first web application is incorrectly applied to all others. This can lead to authentication bypass or cross-application authentication issues. The vulnerability affects Apache Tomcat versions from 8.5.0 through 8.5.100, 9.0.0.M4 through 9.0.121, 10.1.0-M1 through 10.1.59, and 11.0.0-M1 through 11.0.25. Fixed versions are 8.5.101, 9.0.122, 10.1.60, and 11.0.26. The CVSS score is 7.3 (high severity).

References

Community reviews

Loading reviews…