Skip to main content
VulnerabilityPublished Updated

CVE-2026-76187: Apache Airflow Keycloak provider · Improper Authentication

Affects Apache Airflow Keycloak providerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.10.0 as a priority.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow Keycloak provider and apache-airflow-providers-keycloak to 0.10.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Airflow Keycloak providerAffected
  • <0.10.0
Fixed in
  • 0.10.0
PyPIapache-airflow-providers-keycloakpkg:pypi/apache-airflow-providers-keycloakOther threatsAffected
  • <0.10.0
Fixed in
  • 0.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to apache-airflow-providers-keycloak version 0.10.0 or later, which restricts client-credentials grants to only the configured client, preventing unauthorized authentication. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-76187 is a critical improper authentication vulnerability in the Apache Airflow Keycloak provider. The unauthenticated token endpoint accepts client-credentials grants from any confidential client registered in the shared Keycloak realm, not just the client configured for Airflow. This allows an attacker with valid credentials for any client in the realm to authenticate as that client in Airflow and obtain a signed session token. The vulnerability affects deployments using the Keycloak auth manager with a shared realm among multiple confidential clients. Upgrading to apache-airflow-providers-keycloak version 0.10.0 or later mitigates this issue by restricting authentication to the configured client only.

References

Community reviews

Loading reviews…