CVE-2026-79916: 1Panel-dev MaxKB · OS Command Injection
Affects 1Panel-dev MaxKBSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.10.5-lts as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.5-lts
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade MaxKB and 1panel-dev/MaxKB to 2.10.5-lts.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devMaxKB | Affected
| Fixed in
|
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in MaxKB version 2.10.5-lts. Users should upgrade to 2.10.5-lts or later to remediate this issue. Since this is a cloud service, the vendor manages remediation for hosted instances; verify with the vendor that the service is updated. No additional mitigation is required if the fix is applied.
Description
CVE-2026-79916 is a critical OS command injection vulnerability in MaxKB, an open-source AI assistant for enterprise. Authenticated workspace members prior to version 2.10.5-lts can inject control characters into AWS credentials fields, leading to execution of attacker-controlled commands as root. The vulnerability is fixed in version 2.10.5-lts.
References
- github.com/1Panel-dev/MaxKB/security/advisories/GHSA-2324-7xjr-9qxg (opens in a new tab)
- github.com/1Panel-dev/MaxKB/pull/6418 (opens in a new tab)
- github.com/1Panel-dev/MaxKB/commit/a1e413d196004421ab0953ee0baa13d4ca0fe3c4 (opens in a new tab)
- github.com/1Panel-dev/MaxKB/releases/tag/v2.10.5-lts (opens in a new tab)