Skip to main content
VulnerabilityPublished

CVE-2026-39417: 1Panel-dev MaxKB · OS Command Injection

Affects 1Panel-dev MaxKBSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 4.6 Medium : upgrade to 2.8.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade MaxKB and 1panel-dev/MaxKB to 2.8.0.

Affected software

ProductAffectedFixed in
1Panel-devMaxKBAffected
  • <2.8.0
Fixed in
  • 2.8.0
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threatsAffected
  • <2.8.0
Fixed in
  • 2.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in MaxKB version 2.8.0. Users should upgrade to version 2.8.0 or later to remediate this issue. Until upgrading, avoid exposing the workflow creation API to untrusted users to reduce risk.

Description

CVE-2026-39417 is an OS command injection vulnerability in 1Panel-dev MaxKB versions 2.7.1 and below. It arises from an incomplete fix for a previous vulnerability (CVE-2025-53928) where the MCP node configuration can still be injected via user-supplied JSON in the workflow creation API. This allows an attacker with limited privileges to inject arbitrary commands that execute when the workflow is triggered. The issue is fixed in version 2.8.0. The CVSS score is 4.6, indicating medium severity.

References

Community reviews

Loading reviews…