CVE-2026-8053: MongoDB Server · Out-of-bounds Write
Affects MongoDB ServerSource CVE Database V5
Not known to be exploited · CVSS 8.7 High · fixed in 8.3.2 : patch MongoDB Server soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.3.2, 8.2.9, 8.0.23 +3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDB, Inc.MongoDB Server | Affected
| Fixed in
|
| MongoDB, Inc.MongoDB Server | Affected
| Fixed in
|
| MongoDB, Inc.MongoDB Server | Affected
| Fixed in
|
| MongoDB, Inc.MongoDB Server | Affected
| Fixed in
|
| MongoDB, Inc.MongoDB Server | Affected
| Fixed in
|
| MongoDB, Inc.MongoDB Server | Affected
| Fixed in
|
AI-suggested
Until patched, restrict database write privileges to trusted users only to reduce risk.
Description
CVE-2026-8053 is a high-severity vulnerability in MongoDB Server's time-series collection implementation. It allows an authenticated user with database write privileges to cause an out-of-bounds memory write in the mongod process due to an inconsistency in the internal field-name-to-index mapping within the time-series bucket catalog. This flaw can lead to arbitrary code execution under certain conditions. The vulnerability affects multiple MongoDB Server versions prior to 5.0.33, 6.0.28, 7.0.34, 8.