Skip to main content
VulnerabilityPublished Updated

CVE-2026-8336: MongoDB Server · Use After Free

Affects MongoDB ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 8.3.2 or 8.2.9 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.2, 8.2.9
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/AU:N/R:A/V:D/RE:M/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade MongoDB Server to 8.3.2 or 8.2.9.

Affected software

ProductAffectedFixed in
MongoDB, Inc.MongoDB ServerAffected
  • >=8.3 <8.3.2
Fixed in
  • 8.3.2
MongoDB, Inc.MongoDB ServerAffected
  • >=8.2 <8.2.9
Fixed in
  • 8.2.9

AI-suggested

advisories for updates. If you cannot patch yet, restrict access to authenticated users and avoid using the affected server-side JavaScript features in ways that could trigger the vulnerability if possible.

Description

After invoking $_internalJsEmit, which is not intended to be directly accessible, or mapreduce command’s map function in a certain way, an authenticated user can subsequently crash mongod when the server-side JavaScript engine (through $where, $function, mapreduce reduce stage, etc.) is used also in a specific way, resulting in a post-authentication denial-of-service. This issue impacts MongoDB Server v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.

References

Community reviews

Loading reviews…